IKLAN

Pelatihan
&
Jasa Setting Proxy High Perfomance

Di Jamin Youtube tercache & Game online terupdate cepat
  • Pelatihan & Setting On the site
Mobile Phone:085868788968
Pin BB:52595EA2
BUTUH MOBIL BARU/BEKAS?

DP minimal 30 % dari harga mobil baru atau bekas. Syarat untuk karyawan/pns: Fotokopi KTP pemohon, Kartu Keluarga, Rincian Gaji, Rekening Listrik, Surat/Akta nikah, Telepon, PDAM, PBB, Rekening Tabungan & NPWP
Syarat untuk wiraswata:Plus SIUP/TDP, Laporan keuangan terakhir
Contact Person : Eka (082227594993)
Pin BB : 52595EA2

Jasa Pembuatan RT RW Net dan Warnet

Modal Hanya 5 JT-an..!!!

Meliputi:

=>Radio Access Point TP-LINK

=>Antena OMNI

=>Pigtail

=>Kabel UTP 25 meter

=>CPU P3 Mikrotik 2nd, CPU Dual COre Proxy Server 2nd dan Tower 3 Pipa Galvanis

Keuntungan

=>Lebih Murah dalam 1 paket komplit

=>RT/RW-Net Siap Pakai

=>PJK akan membantu promosi

Call/SMS = 085868788968
Pin BB :52595EA2


SEWA MOBIL PEKALONGAN DAN BATANG
Sewa/Carter Mobil Dalam Kota / Luar Kota (Se-Jawa) + Sopir.
Hubungi: Eka HP: 085868788968 / 082227594993
Pin BB : 52595EA2
Alamat:
Jl. Akasia Raya No.5 Perumahan Kalisalak Batang
Jl. Trapesium 3 No.15 Perumahan Limas Indah Pekalongan


SPACE INI DI SEWAKAN UNTUK IKLAN

Hubungi :

Mobile Phone:085868788968
Pin BB:52595EA2




About Me

My photo

I was born on 11th July 1978 in Pekalongan,Central Java Province,Indonesia.I have been running my own business (Putra Jaya Komputer) for mor 15 years in Pekalongan city and Batang Regency. On 2014 I am starting a new business is a rent a car. If any one who has a plan to visit Indonesia don't hesitate contact me.

Blog Archive

Popular Posts

Home » » MEMBUAT PROXY DENGAN LUSCA HEAD

MEMBUAT PROXY DENGAN LUSCA HEAD


IP modem : 192.200.1.1/24
IP mikrotik:
Ether1/wan:192.200.1.2/24, gateway;192.200.1.1
Ether2/proxy:192.168.10.2/24
Ether3/lan : 192.168.1.1/24
IP Mesin Proxy : 192.168.10.1/24, gateway : 192.168.10.2
Alat yang di butuhkan :
  1. mikrotik router dengan 3 ether
  2. mesin squid dengan 1 ether
kita asumsikan mikrotik sudah terinstall dengan baik, dan mesin squid terinstall dengan baik juga, distro yang saya gunakan ubuntu server 10.10 dan squid 2.7 stable9. Upgrade ke LUSCA

Instalasi UBUNTU Server 10.10
1. MASUKKAN CD UBUNTU KE CDROM DAN boot pilih ke cdroom,
2. Pilih language english (enter)
3. Pilih instal ubuntu server (enter)
4. Tekan enter pada choose langguage english
5. Pilih united states
6. Klik no pada detect keyboard layout?
7. Klik USA pada ubuntu installer main menu
8. Klik USA pada keyboard layout
9. Klik continue pada configure the network
10. Pilih configure network manually isi ip address dg 192.168.10.1 pilih continue enter
11. Netmask 255.255.255.0 pilih continue enter
12. Gateway 192.168.10.2 terus klik continue
13. Name server addresses 192.168.10.2 pilih continue enter
14. Hotsnama : isi dg proxyku terus pilih continue enter
15. Domain name: di kosongin saja, pilih continue enter
16. Pada configure the clok pilih select from worldwide list terus cari jakarta (sesuaikan lokasi anda) terus enter
17. Pada menu partition disk pilih manual
18. Kita hapus partisi lama dulu :
19. Pilih partisi nya terus enter pilih delete the partion (ulangi perintah ini untuk semua partisi yg tersisa)
20. Jika telah selesai pilih Guided partitioning, kemudian pilih manual arahkan pada FREE SPACE (enter),
21. Pilih Create new partition (enter)
22. New partition size isi 256 mb (pilih continue dan enter), pilih Primary (enter), pilih Beginning (enter), pada use as pilih EXT4 (enter) pada Mount point pilih /boot (enter), pd mount option pilih[*]
noatime (pilih continue dan enter), pada Bootable Flag rubah menjadi on JIKA STATUS NYA TDK BERUBAH ABAIKAN SAJA kemudian pilih done setting up the partition
23. New partition size isi 20 gb (pilih continue dan enter), pilih Primary (enter), pilih Beginning (enter), pada use as pilih EXT4 (enter) pada Mount point pilih / (enter), pd mount option pilih[*] noatime
(pilih continue dan enter), kemudian pilih done setting up the partition
24. Arahkan pada FREE SPACE (enter), pilih Create new partition (enter) new partition size isi 4 gb ( besarnya 2x RAM) pilih continue dan enter, pilih Primary (enter), pilih Beginning (enter), pada use as
pilih swap area (enter), kemudian Pilih done setting up the partition
25. Arahkan pada FREE SPACE (enter), pilih Create new partition (enter) new partition size isi sisa semua harddisk (pilih continue dan enter), pilih Primary (enter), pilih Beginning (enter),
pada use as pilih btrFS atau Reinsfers (enter)
CATATAN :
btrFs untuk 64bit
Reinfers untuk 32bit
pada Moun point enter manually buat menjadi /cache, pd mount option pilih[*] noatime dan realtime kemudian Pilih continue dan done setting up the partition
26. Kemudian pilih finis partitioning and write changes to disk, write the changes to disk pilih yes
27. pada full name for the new user isi dg proxyku, terus continue & enter
28. pada Username for your account isi dg proxyku, terus continue & enter
29. pada a password for the new user isi dg proxyku, terus continue & enter
30. pada re-enter password to verify isi dg proxyku, terus continue & enter
31. pada use weak password pilih yes
32. pada encrypt your home directory pilih no
33. pada HTTP proxy information KOSONGIN SAJA
34. pada configurasi apt 43% tekan enter, juga pada 81% tekan enter pilih no automatic update
35.pada choose software to install pilih OpenSSH server pilih continus pd finish the installation dan reboot, ambil CD Ubuntu, 1st Boot kembalikan ke Hardisk
selanjutnya
# login dg proxyku
# password proxyku
# ketik sudo su -
# isi proxyku
jika menginginkan login sebagai root setiap reboot ubuntu ikuti langkah berikut :
# ketik passwd
# enter new UNIX password isi dg proxyku
# retype new UNIX password isi proxyku
kemudian update terlebih dahulu ubuntu:
# sudo apt-get update
# sudo apt-get install squid squidclient squid-cgi
# sudo apt-get install gcc
# sudo apt-get install build-essential
# sudo apt-get install sharutils
# sudo apt-get install ccze
# sudo apt-get install libzip-dev
# sudo apt-get install automake1.9
#reboot
==================================================================
Pasang kabel cross PC-Proxy ke eth2 Mikrotik
Kemudian download squid disini
ekstrak dulu dengan winrar di windows
Kemudian gunakan aplikasi winscp dan remote pc-proxy tersebut.
copy file LUSCA_FMI.tar.gz yg sudah di download tadi ke dalam /root pc-proxy
close aplikasi winscp
kemudian dari consol pc-proxy masuk ke root@ict:~#
Ekstract file LUSCA_FMI.tar.gz Dengan cara : dari direktori root@ict:~#tar xzvf LUSCA_FMI.tar.gz
Masuk ke folder yang sudah di ekstract tadi root@ict:~# cd LUSCA_FMI
Kemudian Compile squid tersebut, Copas Scrip dibawah ini ke konsol pc-proxy anda .
download dolo boss compilenya
Maka akan tampil seperti ini dilayar anda:

Kemudian lanjutkan dengan perintah :
root@ict:~/LUSCA_FMI#make && make install


Kemudian kita stop squidnya:
root@ict:~/LUSCA_FMI# squid -k shutdown
copy file squid.conf dan storeurl.pl yg telah di download tadi ke dalam /etc/squid/
copy dengan aplikasi winscp .
kita buat permision untuk squid.conf dan storeurl.pl

root@ict:/#chown proxy:proxy /etc/squid/storeurl.pl
root@ict:/#chmod 777 /etc/squid/storeurl.pl
root@ict:/#chmod 600 /etc/squid/squid.conf

sekarang kita buat cache_dir nya:
root@ict:/#mkdir cache
root@ict:/#cd /cache
chmod 777 /cache
chown proxy:proxy /cache
kemudian edit file squid.conf
#mcedit /etc/squid/squid.conf
sesuaikan Network anda pada ACL Localnya ganti dengan network pc-proxy anda 192.168.10.0/24
kemudian ip client 192.168.1.0/24
sesuaikan gatewaynya 192.168.10.2
kemudian : cache_dir aufs /cache 100000 64 256 #200000ß—- menunjukan besar HDD untuk cache 100 GB
simpan dengan tombol f10
sekarang kita buat swap untuk cache_dir nya
#squid -f /etc/squid/squid.conf -z
sekarang jalankan squidnya
#squid -N -d 1 -D
# reboot
Setelah reboot cek squidnya
Kemudian dari winbox kita konfigurasikan mangle-nya:
karena mikrotik yg di pake 3.xx maka tos nya =12
/ip firewall mangle
add action=mark-packet chain=prerouting comment=PROXY-HIT disabled=no dscp=12 new-packet-mark=proxy-hit passthrough=no
add action=mark-connection chain=prerouting comment=http-conn disabled=no dst-port=80 new-connection-mark=http-conn passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=”" connection-mark=http-conn disabled=no new-packet-mark=http passthrough=yes
add action=mark-connection chain=prerouting comment=https-conn connection-state=new disabled=no dst-port=443 new-connection-mark=https-conn passthrough=yes \
protocol=tcp
add action=mark-routing chain=prerouting comment=”" connection-mark=https-conn disabled=no new-routing-mark=https passthrough=no
add action=mark-connection chain=prerouting comment=DNS disabled=no dst-port=53 new-connection-mark=DNS passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”" disabled=no dst-port=53 new-connection-mark=DNS passthrough=yes protocol=udp
add action=change-dscp chain=prerouting comment=”" connection-mark=DNS disabled=no new-dscp=12
add action=mark-packet chain=prerouting comment=”DNS Paket” connection-mark=DNS disabled=no new-packet-mark=DNS_PACKET passthrough=no
add action=mark-packet chain=prerouting comment=”" disabled=no new-packet-mark=DNS_PACKET passthrough=yes
add action=mark-connection chain=forward comment=YM-Conn disabled=no dst-port=5050,5100,5051 new-connection-mark=YM passthrough=no protocol=tcp
add action=mark-connection chain=forward comment=”" connection-mark=YM disabled=no new-connection-mark=YM passthrough=yes
add action=mark-connection chain=input comment=Winbox disabled=no dst-port=8291 new-connection-mark=winbox passthrough=no protocol=tcp
add action=change-mss chain=forward comment=”CHANGE MMS” disabled=no in-interface=ether1 new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=change-mss chain=forward comment=”" disabled=no new-mss=1440 out-interface=ether1 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=accept chain=forward comment=”Total Pemakaian” disabled=no in-interface=ether1
add action=mark-connection chain=forward comment=POKER-CONN disabled=no dst-port=843,9339,39100,39110,39220,39190,49100,19101,19000,4300 new-connection-mark=\
POKER passthrough=no protocol=tcp
add action=mark-connection chain=forward comment=”" connection-mark=POKER disabled=no new-connection-mark=POKER passthrough=yes

Setelah selesai konfigurasi mangle sambil browsing cek log pada squid dari pc-proxy:
tail –f /var/log/squid/access.log |grep HIT